56f955fcb14dfresizedown960px420px16
Категория Работа с базой данных
Тип расширения Плагин 
Совместимость с Joomla 3.x 
Распространение Коммерческое

Добавьте расширение к себе на стену, чтобы не забыть:

Этот плагин для версий Joomla 2.5 и 3.x позволяет производить транслитерацию символов кодировки в автоматическом режиме включая информацию в базах данных и даже наборах символов в строках и столбцах. Дополнительно возможно преобразование символов в таблицах от MyISAM до InnoDB. Технические вопросы связанные с обслуживанием оборудования и программного обеспечения на сегодняшний день отнимают львиную долю времени и сил. Не каждый человек способен самостоятельно разобраться и осуществить требуемые действия. Для решения всех вероятных проблем Вы всегда можете обратиться к профессионалам своего дела, которые быстро и качественно выполнят работы любой сложности, для которых не существует неразрешимых задач, например, Вы можете обратиться к группе компаний https://www.nav-it.ru/services/tekhnicheskoe-obsluzhivanie/.

Новая версия Joomla 3.5 разработана таким образом, чтобы поддерживать в работе с кодировкой UTF8mb4 и движком InnoDB MySQL. Эти внедрения позволяют Вам использовать символы эмодзи и другие многобайтные символы, такие как традиционные китайские глифы, язык чероки и т.д. В этом случае Вы должны изменить кодировку на “Мультибайт UTF-8”. Joomla 3.5 выполняет это преобразование для всех собственных основных таблиц, модернизируя до новейшей Версии Joomla. Но, вероятнее всего, Вам возможно, придется повторить все эти шаги для "старых" расширений или для тех расширений которые были установлены или модернизированы и использовали другую базовую кодировку. После установки новых расширений Вам настоятельно рекомендуется это проверить. Если расширение связало поля с различными кодировками тогда, это может привести к возникновению ошибки: "Неправильное соединение кодировок".

Все необходимые изменения доступны Вам в режиме бекэнда на сайте Joomla.

Вам просто необходим наш плагин, если Вы испытываете затруднения хотя бы по одному из описанных ниже моментов:

  • Вам необходимо постоянно производить переключение из одной кодировки в другую;
  • Вам необходимо переключиться от MyISAM до InnoDB;
  • У Вас выскакивает ошибка: "Неправильное соединение кодировок";
  • Вам необходимо перевести данные Вашего сайта с версии Joomla 2.5 на версию 3.5;
  • Вы используете на своем сайте сторонние расширения, которые не поддерживают работу с кодировкой UTF8mb4.

С любой из этих проблем легко справиться наш плагин.

56f95606ee084resizedown960px420px1656f956028a7b9resizedown960px420px16